Gerade wollte ich OpenMediaVault, eine Linux-Distribution zum Aufsetzen eines eigenen NAS, ausprobieren. Also schnell das entsprechende Image auf eine Micro-SD-Karte gepackt und im Raspberry PI gebootet. Leider stoppte der Boot-Vorgang schon beim Dateisystem-Check der SD-Karten-Partitionen. Mit Tastatur an sich kein Problem. In diesem Fall startet man einfach fsck für die betreffende Partition in der root-Shell. Was aber tun ohne Tastatur?

Der Fehler trat auch dann auf, nachdem ich fsck für die SD-Karten-Partitionen auf meinem Laptop ausgeführt hatte. Die Lösung war recht einfach. OpenMediaVault behauptete, der letzte Mount-Zeitpunkt läge in der Zukunft. Zufällig stolperte ich über eine Datei „/etc/fake-hwclock.data“ auf der „omv“-Partition der SD-Karte. Darin stand „2015-06…“. Nun haben wir aber schon Januar 2016. Also schnell ein Datum aus der Zukunft eingetragen, den Raspberry Pi erneut gebootet und siehe da: es lebt 🙂

Wieder einmal eine Problemlösung aus der Kategorie „wenn einfach einfach einfach ist“.

OpenMediaVault startet nicht auf Raspberry PI
Markiert in:            

2 Gedanken zu „OpenMediaVault startet nicht auf Raspberry PI

  • Freitag, der 12. Februar 2016 um Freitag, der 12. Februar 2016
    Permalink

    Das war es. Ich kämpfe damit schon seid Tagen, da ich keine Tastatur mehr hatte.
    Danke
    Aber warum die da so ein blödes Datum festlegen…

    Antworten
    • Freitag, der 12. Februar 2016 um Freitag, der 12. Februar 2016
      Permalink

      Ich gehe mal davon aus, dass das Release-Datum im File steht (29.06.2015).

      Da der Raspberry PI keine Hardware-Uhr besitzt, wird mit fake-hwclock periodisch die System-Zeit (vom NTP-Dienst) gespeichert. Da das ISO-Image ja nicht andauernd neu erstellt wird, steht also im genannten File die Zeit des Releases 🙂

      Freut mich auf jeden Fall, wenn ich helfen konnte!

      Gruß,
      Piet

      Antworten

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

− 3 = 2